JGap 3.2.2 and Java version question

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

JGap 3.2.2 and Java version question

Ashish Kulkarni-2
Hi
Is JGAP 3.2.2 compatible with java 1.4.2 or do i need java 1.5 to get it working,
i have to integrate it with a project which is using java 1.4.2 , is it possible to do so?

Ashish

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >> http://get.splunk.com/
_______________________________________________
jgap-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgap-users
Reply | Threaded
Open this post in threaded view
|

Re: JGap 3.2.2 and Java version question

Klaus Meffert-5
Ashish,
 
the current JGAP version is only compatible with Java 5 or higher due to usage of the new language constructs, such as generics.
But you could try to work out the generics stuff to a legacy implementation, if you really want to use Java 4 with JGAP (or use an older version of JGAP, I think 3.0 is going with Java 1.4)
 
Best
 
Klaus


From: Ashish Kulkarni [mailto:[hidden email]]
Sent: Tuesday, October 09, 2007 6:04 PM
To: [hidden email]; Klaus Meffert
Subject: JGap 3.2.2 and Java version question

Hi
Is JGAP 3.2.2 compatible with java 1.4.2 or do i need java 1.5 to get it working,
i have to integrate it with a project which is using java 1.4.2 , is it possible to do so?

Ashish

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >> http://get.splunk.com/
_______________________________________________
jgap-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jgap-users